free website stats program
1:23 am - Thursday October 2, 2014

Konfigurasi Router Cisco Sebagai VPN Server Untuk VPN Clients Menggunakan PPTP dan MPPE

Dalam artikel kali ini saya mau berbagi mengenai cara mengkonfigurasi Router Cisco IOS sebagai VPN Server dengan Client VPN nya Windows OS yan menggunakan Point-to-Point Tunnelling Protocol (PPTP), dan Microsoft Point-to-Point Protocol Encryption (MPPE).

Dengan tanpa basa-basi mari kita mulai cara mengkonfigurasinya, sebagai contohnya agar lebih mudah dipahami saya membuatkan network topology-nya seperti gambar 1 dibawah ini :


Gambar 1. Network Topologi.

Sebagai catatan sebelum konfigurasi VPN Server ini dilakukan, basic konfigurasi dan routingan pada Router R1 sudah dibuat dan sudah berjalan dengan baik.

Memulai Konfigurasi Router PPTP :

R1#configure terminal
 Enter configuration commands, one per line. End with CNTL/Z.
!−−− Mengaktifkan virtual private dial−up networking.
 R1(config)#vpdn enable
!−−− Membuat Konfigurasi VPDN group Mode
 R1(config)#vpdn−group 1
!−−− Mengaktifkan Konfigurasi VPDN accept−dialin Mode
 !−−− dan mengizinkan router menerima request dial−in.
 R1(config−vpdn)#accept−dialin
!−−− Membuat PPTP protocol sebagai protokol yang akan digunakan router.
 R1(config−vpdn−acc−in)#protocol pptp
!−−− Menentukan Virtual Interface pada router untuk digunakan vpn client
!−−− pada contoh ini menggunakan interface virtual-template 1 
R1(config−vpdn−acc−in)#virtual−template 1
 R1(config−vpdn−acc−in)#exit
!−−− Membuat IP pool dengan nama "TEST" serta memberikan IP range yang akan digunakan vpn client.
 R1(config)#ip local pool TEST 192.168.168.1 192.168.168.20
 !−−− Membuat virtual−template interface yang akan digunakan
!−−− Virtual−access interfaces ini menggunakan ip address dari ip pool "TEST"
  !−−− dan menggunakan autentikasi protokol (CHAP), PAP, and MS−CHAP.
 R1(config)#interface virtual−template 1
 R1(config−if)#encapsulation ppp
 R1(config−if)#peer default ip address pool test
!−−− Virtual -Access interface ini menggunakan Interface pada router R1 yang terkoneksi ke Internet.
 R1(config−if)#ip unnumbered FastEthernet0/0
 R1(config−if)#no keepalive
 R1(config−if)#ppp encrypt mppe auto
 R1(config−if)#ppp authentication pap chap ms−chap
!−−− Membuat User Account untuk user vpn client.
R1(config)#username webmedia password webmedia1
 R1(config)#username teknonesia password teknonesia1

Untuk hasil Lengkap Konfigurasinya dapat kita lihat dengan menjalankan command “show run”

R1#show run
 Building configuration...
 Current configuration : 1566 bytes
 !
 username webmedia password 0 webmedia1
 username teknonesia password 0 teknonesia1
 ip subnet−zero
 ip cef
 !
 !
 no ip domain lookup
 ip domain name teknonesia.com
 !
 vpdn enable
 !
 vpdn−group 1
 ! Default PPTP VPDN group.
 accept−dialin
 protocol pptp
 virtual−template 1
 !
 interface FastEthernet0/0
 ip address 202.152.152.1 255.255.255.248
 duplex auto
 speed auto
 !
 interface FastEthernet0/1
 ip address 10.10.10.254 255.255.255.0
 duplex auto
 speed auto
 !
 interface Virtual−Template1
 ip unnumbered FastEthernet0/0
 peer default ip address pool test
 no keepalive
 ppp encrypt mppe auto
 ppp authentication pap chap ms−chap
 !
 ip local pool test 192.168.168.1 192.168.168.20
 ip http server
 ip http secure−server
 ip classless
 ip route 0.0.0.0 0.0.0.0 202.152.152.14
 !
line con 0
 exec−timeout 0 0
 line aux 0
 line vty 0 4
 login teknonesia1234
 !
 !

Sekarang Konfigurasi VPN Server pada router kita sudah selesai, selanjutnya tinggal melakukan verifikasi dan mengetest koneksi vpn dari computer vpn client.

Untuk Verifikasi Konfigurasi VPN diatas dapat kita lakukan dengan menggunakan command-command dibawah ini :

show debug
show user
show ip route connected
show vpdn

Demikianlah sekilas penjelasan dari saya mengenai konfigurasi dasar server vpn router cisco ini, semoga bermanfaat buat teman-teman sekalian.

Kata kunci:

Filed in: Cisco Networking

3 Responses to “Konfigurasi Router Cisco Sebagai VPN Server Untuk VPN Clients Menggunakan PPTP dan MPPE”

  1. 28/05/2013 at 08:50 #

    Bang Ini Bisa Jalan trus ip nya harus publik ?

  2. 17/06/2013 at 11:21 #

    BAng JAlan ga nih Bang comman nya ku coabain salah 1 ada yang ga bisa

    minta tolong bang caranya :

    yang lengkap aku mau coba neh … di cisco Paket tracer

  3. Ael
    31/12/2013 at 11:41 #

    Gan…

    Untuk confignya di clientnya bagaimana gan?
    apakah router di client menggunakan interface dialer? dan vpdn nya harus enable juga?

Leave a Reply